0

What are the browser requirements?

The site and courses are compatible with web browsers that have been updated within the past three years. Internet Explorer is no longer being updated or supported, so CardioVillage content will not work in the Internet Explorer browser. The site and courses are also available on mobile devices. Some hospital security settings and firewalls may prevent your coursework from checking off as complete; you may wish to complete your course content from a home network or have your hospital IT department whitelist this website.

Leave a Reply